Thread Rating:
  • 4 Vote(s) - 2.75 Average
  • 1
  • 2
  • 3
  • 4
  • 5
84 aspencade radio is crazy!
My radio does stuff I've never see one do...and I assume it's due to shorts or cold solders but I'm just curious if there's something I can do...I can read schematics and solder some so maybe...

The radio jumps bands on it's own all the time and shows numbers and stations that it shouldn't be able too...for instance 92.0 fm or 103.4 fm. The handlebar switches are real sticky and stiff as well which I assume is part of it but can't be all of it. The mute button doesn't even work. The auto volume works every now and then.

What can I do?
Reply
#1 06-13-2010, 02:16 PM,
i would have to say that the first thing you would need to do is send it to sierra electronics for a checkup
once u do that and know that the radio is fixed/operating correctly you can go from there

<!-- m --><a class="postlink" href="http://www.sierra-mc.com/contact.asp">http://www.sierra-mc.com/contact.asp</a><!-- m -->
1987 Aspencade 129K
1986 SEI 93K
2014 Tri-Glide HD 17K

Hancock,MD
Reply
#2 06-13-2010, 04:37 PM,
Good idea, I will put that on next weeks to do list.
Reply
#3 06-14-2010, 04:49 PM,
Time to flush out those handlebar switches, they are full of gunk.

I like to use wd40 to clean them out, just keep spraying them and playing with the buttons over and over until they work consistently, then when they are confirmed good wash out the WD40 with some contact cleaner from Radio Shack.

WD40 is a better cleaner of old contacts, but will leave a residue behind, the contact cleaner is more of a fine contact cleaner, it doesn't 'scour' the older really bad contacts as well, but dries up clean and clear, it is good for regular maint. and for finishing up the job.

I have had to do this on several old bikes and truck switches, the stealers wanted $180 parts and $160 labor, I just spray with WD40 and after about 5-10 mins. it works well. Lasted about 14 years with no further problems the first time I did this.

On my current bike one of those buttons was not working and I did this, about two months later I had the same issue, a second and much quicker cleaning and no more problems in six years.

You might just have a grain of sand/debris washed in there that needs flushing out, or it could be corroded, either way the WD40 will do the job.
'RIDE TO BE SEEN' :d

Most common quote from a cager after killing a motorcyclist.

"I never saw him" instead of "I never looked for him".
Reply
#4 06-14-2010, 06:06 PM,
I might add a soaking with varsol for a real stubborn switch always following up with wd40 and contact cleaner.
The only stupid questions are the one's that are not asked.

Reply
#5 06-14-2010, 06:42 PM,
Well the switches in good shape now...and still the radio acts no better. When you tap on the unit in-dash, you get all kinds of pops and squeaks and nasty sounds from the speakers...sounds like shorts to me. Looks like I've got real work ahead.
Reply
#6 06-15-2010, 08:45 PM,
beltzer047 Wrote:Well the switches in good shape now...and still the radio acts no better. When you tap on the unit in-dash, you get all kinds of pops and squeaks and nasty sounds from the speakers...sounds like shorts to me. Looks like I've got real work ahead.


OK next thing to try.

After a lot of bouncing around over the years, the contacts at the back of the radio can tend to loosen.

Remove the radio, and very carefully open the contacts at the socket so that they will make a better contact when the radio is slid back in.

Also make sure that the contacts are clean
The only stupid questions are the one's that are not asked.

Reply
#7 06-15-2010, 09:36 PM,


Possibly Related Threads…
Thread Author Replies Views Last Post
  1984 Aspencade radio volume Cornhusker Joe 0 75 12-14-2019, 11:28 PM
Last Post: Cornhusker Joe
  84 GW Aspencade Radio Markfeather 2 459 08-01-2013, 07:56 AM
Last Post: firstwing85
  where to start...dead radio on 84 aspencade cwt580 16 746 08-12-2010, 01:36 PM
Last Post: cwt580
  radio on my 1985 aspencade HELP 13 1,034 06-07-2009, 06:30 AM
Last Post: Guest
  85 Aspy Radio going crazy GTi Giant 19 786 05-30-2008, 12:50 PM
Last Post: SIR tricky
  need a radio mount for my 84 Aspencade yiterp 7 706 09-18-2007, 02:33 PM
Last Post: yiterp

Forum Jump:


Users browsing this thread: 1 Guest(s)

Contact Us | GL1200 GOLDWINGS | Return to Top | | Lite (Archive) Mode | RSS Syndication
google-site-verification: googled4b4fe31e07b65d8.html