Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Campbell`s electronics Charging system harness
heck the govt and drug companies sold us billions of dollars because of h1n1 vaccines when it hasn't been any worse than regular flu

than there's global warming....hmmmm DONT GET ME STARTED ON THAT GRRRRRRRR

i still haven't figured how to take it all with me when i die,but the govt has sure figured a way to take it from me before i do :d :d :d :YMPEACE: :YMPEACE: :YMPEACE: :YMPEACE: :YMPEACE:
1987 Aspencade 129K
1986 SEI 93K
2014 Tri-Glide HD 17K

Hancock,MD
Reply
#31 02-25-2010, 07:26 PM,
edbikerii Wrote:Are you still running on the original stator?

jcmaun Wrote:Well, can only speak of my own experience. Installed a Campbell harness on my bike in 1993. It then had 56,000. Maybe harness was better quality then. Came with a relay. Bike now has 132,000 and runs fine.


Nope. Replaced it about the same time. No problem since.
JCMaun
1985 GL1200 Aspencade
1985 VF700S
1985 VF500C

[Image: 54u6wo.jpg][Image: 8wwpj8.jpg]
Reply
#32 02-26-2010, 08:53 AM,
glhonda Wrote:
neoracer Wrote:a completey easier solution to the possible low voltage and poor spark situation
Is there still another problem with the 1200 that I'm not aware of?

As far as I'm concerned the stock GL1200 ignition system is nearly bullet proof aside from the pulse generators.
Ed (Vic) Belanger - 1954-2015
Founder of gl1200goldwings.com

Reply
#33 02-26-2010, 01:55 PM,
admin Wrote:As far as I'm concerned the stock GL1200 ignition system is nearly bullet proof aside from the pulse generators.
Thanks Vic, that was my point. Aside from an occasional pulse generator and a coil here and there, the 1200 ignition gives great service. I've always maintained that all "mods" aren't necessary, unless they overcome a potentially bad condition. The ignition system doesn't qualify. If the 1200 had as many "problems" as some make out, I wouldn't own one!
Reply
#34 02-26-2010, 06:42 PM,
When I traded for my 1200 the lights were dim the turn signals and horn worked erratic. The voltage to the fuse panel was 9.5 volts, replaced two hacked wires to the key switch cleaned several connections, then voltage was 11.5 . After replacing open stator with external alternator there is 12.5 at fuse panel. Was able to ride bike 6 months before the stator failed, the increase in voltage has increased performance !
joe
Reply
#35 02-26-2010, 07:27 PM,
I talked to Lewis at Electrical Connection on the phone about how to modify his GL1200 harness to work with Poor Boy's kit. First, he said he's had a few calls now asking how to use external alternator with his harness. Half the harness doesn't get used so he has completed a second harness that is just the coil/relay set up. However if you have his original harness he says just cut and cap the three yellow stator wires and disconnect the large red wire with the 40 amp fuse connecting to the battery. The smaller red wire with the 15 amp fuse stays connected at battery as that's the power source for the coil and relay.

I cut the large red wire farther up in his harness. I had to remove the sleeve he used to help protect the harness. I cut it where it split to two smaller red wires. I'm going to solder the wire that goes to the output at the alternator. I'm doing this because the connector at the battery is very well done and it incorporates the coil power. Making for a nice clean battery connection. Of course I'll upgrade the fuse to 50 amp.
[Image: VisitedProvincesMap.jpg]
[Image: VisitedStatesMap_zps8229ee64.jpg]
Reply
#36 03-03-2010, 06:49 PM,
I just bought a DC harness. I know everyone has their opinions about him but I just needs some help. I am restoring a 1985 GL1200I and I need some help. If there is anyone out there who has ever installed this type of harness and is willing to give advice like "wiring for dummies" I would really appreciate it.
Reply
#37 05-04-2010, 05:14 PM,
copman70 Wrote:I just bought a DC harness. I know everyone has their opinions about him but I just needs some help. I am restoring a 1985 GL1200I and I need some help. If there is anyone out there who has ever installed this type of harness and is willing to give advice like "wiring for dummies" I would really appreciate it.
Sorry to be blunt but if it didn't come with good instructions throw it in the trash and cut your losses.

If you look through the forum you'll find instructions on how to fix most if not all of the wiring problems you'll run into.
Reply
#38 05-04-2010, 06:14 PM,


Possibly Related Threads…
Thread Author Replies Views Last Post
  Charging system voltage Jim Penner 8 1,988 08-11-2019, 11:59 AM
Last Post: glhonda
  charging system question yiterp 5 731 05-08-2013, 01:42 PM
Last Post: neoracer
  Charging System Problem BikerNewsman 28 3,276 07-25-2012, 03:32 PM
Last Post: bs175dths
  Found Problem. Was NOT the charging system MikeM 3 908 12-05-2011, 06:17 AM
Last Post: Roleketu
  charging system issues/ stator issues 9 1,211 12-07-2010, 08:07 AM
Last Post: Guest
  Re: Charging System Problem tgsguitar 3 577 05-18-2010, 03:59 PM
Last Post: SIR tricky
  Charging System Failure Alert!! William_86 6 1,112 04-20-2010, 12:04 PM
Last Post: Roleketu
  charging system irregularity Jim Penner 31 2,437 11-22-2009, 03:54 PM
Last Post: Jim Penner
  charging system output? 18 1,482 11-05-2009, 05:10 PM
Last Post: admin
  continuation of the charging system irregularity Jim Penner 14 845 09-16-2009, 08:09 AM
Last Post: neoracer

Forum Jump:


Users browsing this thread: 1 Guest(s)

Contact Us | GL1200 GOLDWINGS | Return to Top | | Lite (Archive) Mode | RSS Syndication
google-site-verification: googled4b4fe31e07b65d8.html