Thread Rating:
  • 4 Vote(s) - 3.25 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Speedometer problem
Today while riding my speedometer just turned to 0 and is not working now at all. I don't even know where to start with this one, can someone help PLEASE. Thank you
#1 09-17-2008, 02:47 PM,
if it's the digital dash, your speedo drive sensor isn't working.

while there is a test in the manual, I don't have it right at hand Sad

if however you pull the sensor off the left axle mount, you can visually check the gear to see if it didn't take a dump on you.

had that problem a couple of years ago, and the gears are available.
#2 09-17-2008, 03:49 PM,
Hello, I had the same problem a month ago on my aspy. Pulled the sensor apart to find corrosion and rust cleaned it up and put electrical grease on internal wheel. It has worked since! The electronic sensor is down by the wheel.

Good luck Keith
#3 09-17-2008, 05:10 PM,
If it's not the digital dash, then it's most likely the speedo cable. Not that expensive, but you have to take the windshield off to replace it. I once tried just replacing just the inner core, it was cheaper and a lot easier to do, but it didn’t last very long. When the old cable went, it must have damaged the inside of the old housing and that destroyed the new one in a few short miles.
#4 09-19-2008, 10:16 AM,

Possibly Related Threads…
Thread Author Replies Views Last Post
  Speedometer problem 1 649 09-17-2008, 06:39 PM
Last Post: Guest

Forum Jump:

Users browsing this thread: 1 Guest(s)

Contact Us | GL1200 GOLDWINGS | Return to Top | | Lite (Archive) Mode | RSS Syndication
google-site-verification: googled4b4fe31e07b65d8.html