Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Flickering instrument panel
I spent quite a bit of time cleaning carbs and adjusting for a smooth ride this fall. Now that I've re-assembled the front fairing I've got an instrument panel that flickers like power is coming and going, the radio flickers without fully powering on, runs a little rough, and a tail-light indicator is on. If I pull the hand brake, the tail light indicator goes off, radio powers on, and most of the flickering of the instruments goes away and powers on. Plug wires seem to be connected, and the tail light is on and gets bright when I pull the hand brake. Any thoughts on how I can start chasing down this problem?
Brian
Reply
#1 11-07-2020, 09:08 AM,
I'd start looking for a bad ground. Maybe jump a known ground to the fairing ground and/or check the ground pin in the connectors for the fairing.
Reply
#2 11-08-2020, 08:13 AM,


Possibly Related Threads…
Thread Author Replies Views Last Post
  Rear lights all flickering problem on indicating only steelhorseangel 19 2,234 11-12-2014, 01:19 PM
Last Post: steelhorseangel
  Instrument Panel and Tail Light Bulb Replacement BikerNewsman 4 587 06-13-2012, 04:39 PM
Last Post: Usblack129
  Question: Back Light of the Instrument Panel William_86 3 483 12-09-2007, 07:20 AM
Last Post: Guest

Forum Jump:


Users browsing this thread: 1 Guest(s)

Contact Us | GL1200 GOLDWINGS | Return to Top | | Lite (Archive) Mode | RSS Syndication
google-site-verification: googled4b4fe31e07b65d8.html