Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
86 SEI CB RADIO DISPLAY NOT WORKING RIGHT
86 SEI The display on the cb started showing 88 or just a garbled number when I change it. The cb works but I don't know what channel it's on. The only thing I have done is changed the battery. any ideas?? thks

Syringa
Reply
#1 12-28-2013, 08:04 AM,
DO NOT DOUBLE POST

welcome to the club..... mine is the same, I tried to get it fixed but to no avail. I only use the one channel when riding so I leave it on that channel. If you get it figured out let us all know
The only stupid questions are the one's that are not asked.

Reply
#2 12-28-2013, 01:25 PM,
had same problem and SIERRA had tp replace a board in it,appears to work ok but haven't ridden it with friends that have cb's
1987 Aspencade 129K
1986 SEI 93K
2014 Tri-Glide HD 17K

Hancock,MD
Reply
#3 12-28-2013, 10:04 PM,


Possibly Related Threads…
Thread Author Replies Views Last Post
  Time to get this radio working! MrShake 16 783 07-24-2011, 01:53 PM
Last Post: neoracer
  Radio, voltmeter, outside temp display and clock not working roys654 2 275 12-30-2010, 03:40 PM
Last Post: BladeRunner
  Radio channel display 8 500 09-01-2009, 09:50 AM
Last Post: admin
  1200 Travel Computer Display not working! Mike 13 1,149 10-10-2007, 05:08 PM
Last Post: catman

Forum Jump:


Users browsing this thread: 1 Guest(s)

Contact Us | GL1200 GOLDWINGS | Return to Top | | Lite (Archive) Mode | RSS Syndication
google-site-verification: googled4b4fe31e07b65d8.html