Thread Rating:
  • 1 Vote(s) - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
84 GW Aspencade Radio
Hi guys and gals, new to the GW and have a few questions about my radio. The right side speaker does not work and when I hit a bump etc I hear a lot of static.

I have installed new speakers and will check wiring on the right one but any other good ideas for the static?

Any one in the VA Area that is knowledgeable about this model, i would love to catch up for a coke or lunch something.

I am in Northern Virginia near Dulles Airport.

Thanks

Mark
Reply
#1 07-31-2013, 06:49 PM,
welcome to the forum from the mid md/pa area

most likely your contacts on the back of the radio either need cleaning or adjustment,its also possible that the connection on the speaker doesn't have good contact or has fallen off,i usually rewire mine so they have a plug connection

does your radio work correctly when attached to helmet speakers?
1987 Aspencade 129K
1986 SEI 93K
2014 Tri-Glide HD 17K

Hancock,MD
Reply
#2 07-31-2013, 07:08 PM,
hello Mark, welcome to the forum.
Johan
Reply
#3 08-01-2013, 07:56 AM,


Possibly Related Threads…
Thread Author Replies Views Last Post
  1984 Aspencade radio volume Cornhusker Joe 0 26 12-14-2019, 11:28 PM
Last Post: Cornhusker Joe
  where to start...dead radio on 84 aspencade cwt580 16 692 08-12-2010, 01:36 PM
Last Post: cwt580
  84 aspencade radio is crazy! 7 490 06-15-2010, 09:36 PM
Last Post: SIR tricky
  radio on my 1985 aspencade HELP 13 952 06-07-2009, 06:30 AM
Last Post: Guest
  need a radio mount for my 84 Aspencade yiterp 7 644 09-18-2007, 02:33 PM
Last Post: yiterp

Forum Jump:


Users browsing this thread: 1 Guest(s)

Contact Us | GL1200 GOLDWINGS | Return to Top | | Lite (Archive) Mode | RSS Syndication
google-site-verification: googled4b4fe31e07b65d8.html